Versions:  Applicable through version 3.8.x